ES错误Error:Failed to parse mapping [data]:[_ttl] is removed in 5.0

error":{"root_cause":[{"type":"mapper_parsing_exception","reason":"Failed to parse mapping [data]: [_ttl] is removed in 5.0. As a replacement, you should use time based indexes or cron a delete-by-query with a range query on a timestamp field."}]

这个地方其实说的是挺明白了,就是ES的版本不对,5.0版本之后删除了某些方法。这个是因为docker自动下载的时候,是下载了最新版本的镜像,导致ES组件版本不对而报错了。
解决办法:
下载某个特定版本的ES。

©️2020 CSDN 皮肤主题: Age of Ai 设计师:meimeiellie 返回首页